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All Rights Reserved 

Confidential and Proprietary 

 

Legal Disclaimer 

The product described in this documentation may be connected to, and/or communicate 

information and data via, a network interface, which should be connected to a secure network. It is 

your sole responsibility to ensure a secure connection to the network and to establish and maintain 

appropriate measures (such as but not limited to the installation of firewalls, application of 

authentication measures, encryption of data, installation of antivirus programs, etc.) to protect the 

product, the network, your systems, and the interface against any kind of security breach, 

unauthorised access, interference, intrusion, leakage, damage, or corruption or theft of data. We are 

not liable for damages or losses related to any such security breach, unauthorised access, 

interference, intrusion, leakage, damage, or corruption or theft of data. 
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What’s New 

Discover the latest enhancements and additions introduced in MineScape 

Update 5. 

IMPORTANT: Before installing MineScape 2023 Update 5, please update the 

System Services to the latest version, which is available for download in 

the Distribution Portal. This update is mandatory to ensure a smooth installation 

process and the optimal performance of MineScape. Attempting to install 

MineScape without first updating the System Services will result in installation 

issues. 

MineTrust Integration 

MineScape now integrates with Datamine MineTrust—a centralised environment 

for managing project data across connected platforms. Built for the mining 

industry, it enables secure file synchronisation and version control directly within 

MineScape workflows. 

 
The MineTrust Dock in its Connected State, Displaying Available Folders and Interaction 

Options 

Users can connect to a designated server, browse and retrieve project files, and 

perform common file operations such as editing, uploading, downloading, 

versioning, and tagging. All changes are tracked to ensure consistency and 

traceability. 

https://central.minescapesoftware.com/software
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MineTrust integrates seamlessly with MineScape and supports controlled data 

sharing with other Datamine applications. The tool is accessed via the Start Page 

and features a dedicated dock interface for interacting with server-stored files. 

 
The MineTrust Tool in the Start Page 

NOTE: MineTrust is a separate Datamine product that requires its own 

installation, licensing, and deployment. The MineTrust Tool in MineScape is 

included free of charge and can be used to access the MineTrust server if it is 

already deployed in a local network or cloud environment. 

MineScape Now Supports Importing and Exporting .DMX File 

Format 

MineScape now supports importing from and exporting to the Datamine 

Extended (.DMX) format, alongside the legacy Datamine (.DM) format. The new 

format offers built-in compression for significantly smaller file sizes and supports 

up to 2,048 data columns—an improvement over the 256-column limit in the 

legacy format. 

This enhancement applies to the following forms: 

Block Model 

- Output » Data Exchange » Import » Datamine Block Model 

- Output » Data Exchange » Import » Update Cell Attributes 

- Output » Data Exchange » Export » Block Model to Datamine 

CAD 

- Home » Data Exchange » Import 

- Home » Data Exchange » Export 

- Mesh » File » Import 
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- Mesh » File » Export 

Open Cut 

- Strip Planning » Mining Solids » Export to Tempo 

Table Editor 

- Table Editor » File » Import 

- Table Editor » File » Export 

Core 

Explorer Dock 

As part of the MineTrust integration, the MineScape Explorer now supports direct 

upload of files to the MineTrust server using either MineScape or Datamine file 

extensions. This enhancement allows users to choose the appropriate format 

when uploading supported files. 

 
MineScape Explorer Toolbar with New Icons 

Upload options appear based on the selected file type and are available through 

toolbar icons and right-click menus after connecting to MineTrust. 
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Right-click Menus 

Additionally, file names shown in green now indicate temporary files, making 

them easy to identify at a glance. 

 
Temporary File 

Block Model 

Block-Level Reserve Categorisation for Multi-Mesh 

MineScape can now read and categorise individual blocks within a multi-mesh 

file when mesh is used as the data source in reserve categorisation. 

Each mesh block is processed independently, with reserve categorisation results 

written to both the output table file and the metadata of each mesh block, 
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grouped under Categorisation. Adding this information to the metadata is useful 

when the mesh is used for scheduling, and it also makes it easier to apply 

Interactive Filters. 

 
Categorisation Results Shown per Mesh Block 

 
All Table File Values are Written to the Block Metadata 
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Dragline 

Auto Restart Dragline Server 

 
Dragline Server Starts After a Design File is Selected 

The dragline server now automatically starts once users select a working design 

file from the Open Design File Dialog Box, which appears when either the 

Dragline App and a project are opened, or when the Dragline App is selected from 

the Surface Engineering Tab.  

This enhancement also allows users to change the working design file without 

having to close MineScape to restart the dragline server. 

 
Open Design File Dialog Box 

If the selected design file does not contain a design layer, users will be prompted 

to create one in the Current Design File Layer Dialog Box. 

 
Current Design File Layer Dialog Box 
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Dragline Specification Form with Visualisation  

The Dragline Specification Form now includes visualisation using static images 

and arrows. If a measurement field is selected, a red arrow appears on the dragline 

image to show the location and dimension of the corresponding part. 

 
Red Arrow Shows the Location of the Corresponding Part 

Grid Format for Dragline Material Specification  

The Dragline Material Specification Form has been updated to a grid format, 

allowing users to add, edit, and delete multiple specifications.  

 

The Updated Dragline Material Specification Form in Grid Format 

Improved Control to Show and Hide Elements  

The old Hide Design Option has been replaced by six focused buttons— Hide Area, 

Hide Design, Hide Dragline, Hide Lines, Hide Text and Hide Interactive— so users 
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can quickly hide exactly the elements they don’t need in the CAD Window. Hide 

Interactive lets users click individual items to hide. 

 
Before 

  
After 

In addition, a new Make Visible Button allows users to choose which of those 

hidden elements to bring back, while Show All restores every hidden item in one 

click. 

Dragline Report Dock  

The Dragline Material Movement Report is now also accessible via the new 

Dragline Report Dock, which becomes available once the Dragline App is loaded. 

The report will remain empty until users perform one of the following operations 

in the Design Tab:  

 
Dump and Undo Operations in the Design Tab 

If no report file exists, an empty .RPT file will be generated when a section and block 

are opened. 

Previously, the report was only accessible through the Show Material Detail 

Option, which required users to repeatedly access it to generate the latest 

updates—making it less efficient for monitoring ongoing changes. 
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Dragline Report  

Users can also filter the report based on the machine using the Machine Settings 

Icon( ). The dialog box will automatically list all machines available in current 

working section and block. 

 
Machine Settings Dialog Box 
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UG Coal 

Interactive Pillars 

Users can now create large-scale underground designs efficiently using the new 

Interactive Pillars Tool. A complete layout, including panels, pillars, roads, nodes 

and centre-lines can be generated rapidly from a single main centre-line and a 

set of default parameters, which can be adjusted directly from the ribbon and 

with changes instantly visualised in CAD. The design is initially created as 

temporary graphics, allowing for quick iterations before finalising the layout using 

the Commit » Save Design Option.  

 
Interactive Pillars Tab 

More UG Coal Enhancements 

• Pillars from line now accepts multiple input values for pillar length, 

allowing users to generate different pillar lengths 

• Renamed the Solid Outline Option to Outline On/Off 
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Bug Fixes 

Core 

• Fixed an issue where Area values in the Statistics Dock were incorrect 

when multiple polygons were selected. Polygons with a background colour 

were mistakenly included twice in the calculation, resulting in inflated 

totals. 

• Fixed incorrect display of total vertices in the Statistics Dock when 

multiple CAD elements were selected. Some element types caused 

vertices to be counted more than once. Calculations now follow refined 

rules to ensure accurate results. 

• Fixed an issue where user-defined unit settings couldn’t be reverted back 

to the project's default units 

• Fixed intermittent crash issues in MineScape  

• Fixed design file server (dfserver) stability and performance. This includes 

fixes for memory leaks, high-load performance issues, incommunicative 

clients, and improved logging and configuration options.  

• Fixed an issue where the values in the Base Unit and Decimal Fields of the 

Edit Unit Form were transposed 

CAD 

• Fixed an issue where the Move This Vertex Option in RapidCAD incorrectly 

selected the first vertex instead of the nearest vertex for polygons that have 

fill patterns  

• Fixed a crash that occurred when performing Explode Text on text 

elements containing empty text. The function now properly handles and 

skips empty text elements.  



MineScape 2023 Update 5 Release Notes 
 

 

 
15 

 

• Fixed a crash that occurred when rendering large text elements. This also 

resolves an issue causing the CAD Window to temporarily freeze due to 

delayed scene updates.  

• Fixed a crash that occurred when selecting polygons with names ending in 

a single backslash  

• Fixed an issue where imported DWG/DXF polygon elements were 

incorrectly identified as line elements in the Statistics Dock 

• Fixed a performance issue when interactive filter was applied to a large 

mesh file with many blocks expanded on the Display Dock 

• Fixed an issue where users couldn’t select mesh in a rotated view when 

dynamic slicing corridor was applied to it 

Plot Designer 

• Fixed an issue where Custom Paper unexpectedly appeared in the Media 

dropdown list for the Rapid Plot Feature  

• Fixed an issue with horizontal alignment in table detail containers, which 

caused interval texts to be misaligned or hidden when the plot container 

was narrow  

Block Model 

• Fixed a crash that occurred when running reserves categorisation in Block 

Model 

GDB 

• Fixed an issue where GDB-specific plot containers did not display with the 

correct transparency in drill hole plots  

• Fixed an issue where the scale bar value was incorrectly displayed on GDB 

Hole Plot PDF results due to broken container indexing and unintended 

scale adjustments  
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Dragline 

• Fixed an issue where the dragline server didn’t start automatically after 

switching to another dragline project  

• Fixed an issue where opening a new Dragline project caused the Open 

Design File Dialog Box to overlap with the project loading progress bar  

• Fixed an issue where the Open Design File Dialog Box incorrectly 

appeared when opening a blank Dragline project after previously closing 

the project and unloading the Dragline App  

Scheduling 

• Fixed a crash that occurred when running sequence animation 

Tools 

• Fixed an issue in LicenseLogToExcel Tool where total duration was 

calculated using the current year for all dates, sometimes resulting in 

negative values. The correct year is now used based on the recorded 

timestamps.  

Removed 

• Removed the Stand Angle Option from the Dragline Material 

Specification Form and the Dragline Material Details report 


